Joomla Menus Are Missing After A Website Restore

 

We fought this one all weekend. We were moving some Joomla websites from a cPanel server to a Virtualmin server. Everything worked great, except certain website's menu systems were missing. Not only were they missing on the front end of Joomla, they were also missing on the backend. Very strange!

At first we thought it was related to some Artisteer templates we had created. Then we realized that other websites with non-Artisteer templates exibited the same behavior.

We noticed that some of the websites did not have the latest version of Joomla installed. It used to be a pain to keep everything up to date. Not any more. we installed Admin Tools from Akeeba Backup on the Joomla websites in question. Once we updated the them to the latest version of Joomla, the menus appeared on both the fontend and backend areas of Joomla.

How Do I Fix "Warning: call_user_func_array() expects parameter 2"?

 

We were getting this message in certain areas of Joomla when we would attempt to add a link or a picture to an article or module.

We noticed that the website in question did not have the latest version of Joomla installed. It used to be a pain to keep everything up to date. Not any more. We installed Admin Tools from Akeeba Backup on the Joomla websites in question. This didn't resolve the issue, but it's still a good thing to do first.

We use the JCE Content Editor for our Joomla websites. Downloading and installing the most recent version of the JCE content Editor seemed to resolve the issue.

DMEx, Inc.

1715 Mainstreet
Hopkins, MN 55343
(952) 935-9352
info@dmex.com

dmex-facebook

We Accept:

visa master-card american-express discover